Welcome, Autel Pilots!
Join our free Autel drone community today!
Sign up

Im second guessing my purchase. User error or lemon?

Mowerman1

New Member
Joined
Feb 24, 2020
Messages
3
Reaction score
0
Age
46
Like many of you, I’ve enjoyed drones for several years. Previous to that, i’ve been in the rc hobby since Jammin Jay Halsey won his first ROAR Nationals championship. Ive built and operated planes, trains, and automobiles.

After some research, and lack of patience to hold out for the Evo ll, four weeks ago I purchased the rugged bundle thru a big box store as well as their 3 year protection plan that covers “drops, spills, cracks, screen failure, lens failure, and battery failure”.

When I first got the Evo, I was impressed with how quickly I was able to get in the air. Over my first 10 flites, my confidence in it’s flite range grew, and I became less concerned about a fly away, and really just enjoyed taking in the views.

About a week ago, I took the Evo to work so I could map out my property. Explorer app was perfect, and everything operated as designed.

Three days ago, I realized my camera is lagging before I takeoff. I stopped the motors, then restarted the motors and camera on controller returns. I get in the air for some time and land.

Some point later that day, I try to take off, and cant. Magnetic Interference is displayed, as well as another message, that I cant remember. Also sd card wasn't recognizing.

After speaking with Autel customer service, I am told a case would be created, to fill out questionnaire, and they would research options to fix. I did call back with another question, and was educated to perform a manual firmware update.

I’m patiently waiting for a response from Autel. Has anyone else experienced something similar? What are your thoughts?
 

Mowerman1

New Member
Joined
Feb 24, 2020
Messages
3
Reaction score
0
Age
46
Yes, tried to take off at locations I’ve had no issues with before, like my neighborhood and my shop.

Screen is blank (on controller and device). On the rare occasion picture is visible, constantly freezes or is locked up as if you took a picture.
 

DanielC

Well-Known Member
Joined
Aug 13, 2019
Messages
238
Reaction score
108
Age
57
Maybe a new kind of electromagnetic interference in your neighborhood? Or lemon.
 

Mowerman1

New Member
Joined
Feb 24, 2020
Messages
3
Reaction score
0
Age
46
Just to keep everyone updated. I’ve been in touch with Autel. They’ve provided me with shipping docs and my bird has shipped to Washington state.
 

joshmentele

Well-Known Member
Joined
Aug 22, 2017
Messages
261
Reaction score
94
Age
18
Like many of you, I’ve enjoyed drones for several years. Previous to that, i’ve been in the rc hobby since Jammin Jay Halsey won his first ROAR Nationals championship. Ive built and operated planes, trains, and automobiles.

After some research, and lack of patience to hold out for the Evo ll, four weeks ago I purchased the rugged bundle thru a big box store as well as their 3 year protection plan that covers “drops, spills, cracks, screen failure, lens failure, and battery failure”.

When I first got the Evo, I was impressed with how quickly I was able to get in the air. Over my first 10 flites, my confidence in it’s flite range grew, and I became less concerned about a fly away, and really just enjoyed taking in the views.

About a week ago, I took the Evo to work so I could map out my property. Explorer app was perfect, and everything operated as designed.

Three days ago, I realized my camera is lagging before I takeoff. I stopped the motors, then restarted the motors and camera on controller returns. I get in the air for some time and land.

Some point later that day, I try to take off, and cant. Magnetic Interference is displayed, as well as another message, that I cant remember. Also sd card wasn't recognizing.

After speaking with Autel customer service, I am told a case would be created, to fill out questionnaire, and they would research options to fix. I did call back with another question, and was educated to perform a manual firmware update.

I’m patiently waiting for a response from Autel. Has anyone else experienced something similar? What are your thoughts?
It’s possible that your phone don’t have the processing power to handle the video feed but almost any should work nowadays
 

Latest threads

Members online

Forum statistics

Threads
5,483
Messages
52,224
Members
3,605
Latest member
Jeritol