Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

Evo 2 V3 won't connect to controller any more(sort of!)

ahscotty

Member
Joined
Jun 16, 2023
Messages
7
Reaction score
2
Age
48
Today i attempted to fly the Evo2 V3 ,the controller 6.4"(with full battery )started up normally, the aircraft (with full battery) started up normally, but the controller was saying it was disconnected from the aircraft, no video feed and no data was showing on controller. The strange thing is, I was able to arm the drone and take off and hover and land ,but still with the controller saying it was disconnected from aircraft with no data/video feed, so there is some sort of connection. The aircraft operated normally, as in it responded to all stick inputs as it should, but obviously I can't record or any other functions.
I have tried reinstalling latest firmware,no results there, I also just tried re-pairing the remote with aircraft and it tries but quickly says something like "send timed out", so no fix there either.
The controller, app , and aircraft are all running the latest firmware updates and have been since they were available,and has never had any problems running on those updates. The last time I flew the drone a few weeks ago everything operated normally, it has been packed away in its case since then.
The aircraft has never been crashed or even bumped into anything, it has always pretty much flown flawlessly. The aircraft/controller package is only 5 months old and has approx 42 flights logged.
Do anybody have any suggestions on how to fix this problem ,or has this issue happened to anyone else and what might the solution be?
Thanks guys!
 
Last edited:
Unfortunately in my experience the Autel policy regarding the SE Controller for the EVO ll v 3 is SELL IT AND FORGET IT. I’ve had difficulties with mine since purchasing it in December of 2022. I will say that since purchasing a second battery ( so one is always charging ) I’ve been successfully completing most missions… but it’s not dependable and I NEVER see follow up to my emails and phone calls to Autel. Autel Pilot sometimes seem empathetic, but not willing or maybe able to help.
 
Please try to format the SD memory card in your SE remote control until synchronization is completed.
 
I gave it a shot. Hopefully it will perform as advertised now.
Thank you.
 
Did your issue get resolved?
Luckily mine was still under warranty, I had to send it back to the retailer I bought it from (Perth Drone Shop) they got it to work but then the camera wouldn't focus??? They contacted Autel who wanted it sent back to Autel (Indonesia, I think) for assessment,they said this could take several months. A big shout out to Perth Drone Shop (excellent swift customer service and highly recommended to deal with) who deemed this an unreasonable time frame and chose to send me a brand new replacement drone and controller and that they would deal with Autel. So far the new one has been great.
 

Latest threads

Members online

Forum statistics

Threads
11,352
Messages
103,363
Members
10,004
Latest member
mistakcrain