Welcome, Autel Pilots!
Join our free Autel drone community today!
Sign up

Auto take off problem

Joined
Jun 3, 2018
Messages
6
Likes
0
Age
47
#1
I have a 2 yr old Xstar Premium with the latest firmware installed. Never a single problem until now. When I try to auto take off, it lifts off about 2 feet, then comes back down, lands and shuts props down to pre-takeoff speed. If I manually take off it will not hover, it just drops down (a little too fast) and tries to land. Can’t find any settings that would cause this.

Anyone else experience this and find a solution?
 

Goober

Well-Known Member
Joined
Feb 4, 2018
Messages
162
Likes
66
Location
Down the road from Mayberry
#2
Never had that problem, as I always take off/land manually. A quick glance at the manual sez "Auto take off can only be activate after 3 seconds of motor startup and does not work in ATTI mode" - so that would be the first check for me. Might have hit the switch accidentally?
 

Agustine

Well-Known Member
Joined
Jan 18, 2017
Messages
3,332
Likes
1,686
Location
Northern Ontario
#3
Don't think it would be the ATTI mode. If that was on it should not even take off.
So from the info you have provided all this started right after the firmware update is that correct? When the firmware installed were there any errors? You might try another install and see if that helps. This sounds like a problem Autel support would be better suited to try and solve.
 
Joined
Jun 3, 2018
Messages
6
Likes
0
Age
47
#4
Checked ATTI, that wasn’t it. Worked fine after the firmware update for awhile, no errors on the install. Just started doing this out of the blue one day. I’ll try to update again and see what happens.
 

Bace14

Well-Known Member
Joined
May 1, 2018
Messages
52
Likes
14
#5
Checked ATTI, that wasn’t it. Worked fine after the firmware update for awhile, no errors on the install. Just started doing this out of the blue one day. I’ll try to update again and see what happens.
I'm assuming you updated your batteries with the new update? That would cause an issue also.
 
Joined
Jan 9, 2018
Messages
3
Likes
0
Age
60
#6
I have the same issue even when I take off manually it will not hover. I have to manually keep power on or it will crash. I contacted Autel they said that they have heard of this before and to send them the drone to check it out. I am trying one more thing before doing that I have re calibrated the controller.
 
Joined
Jan 9, 2018
Messages
3
Likes
0
Age
60
#9
Well I am going to send mine in as well. It is kinda weird as it worked last year. This year I did the firmware update and now this happens. The Autel rep said it was not due to the firmware.
 
Joined
Jun 3, 2018
Messages
6
Likes
0
Age
47
#10
So...I sent my unit in to Autel. They said the main board needs to be replaced, cost of $217 parts and labor. Kind of strange being I don't have many hours on it, no crashes or anything. But I guess it is what it is. Hopefully that fixes it.
 
Joined
Jan 9, 2018
Messages
3
Likes
0
Age
60
#13
So...I sent my unit in to Autel. They said the main board needs to be replaced, cost of $217 parts and labor. Kind of strange being I don't have many hours on it, no crashes or anything. But I guess it is what it is. Hopefully that fixes it.
Yep I had the same response from Autel total of $217 to replace my drones main board.
 
Last edited:

Latest threads

Members online

Forum statistics

Threads
2,487
Messages
23,247
Members
1,675
Latest member
SublimitySam