Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

V3 Firmware Fixed Yet?

I have copied the newest version of V3 firmware to a micro SD card and uploaded it. After 45% the lights stopped flashing rapidly but continued to load and at 100 % indicated successful. However after hard reboot of drone and V3 controller I still have no control of the gimbal movement. I can zoom in and out but as far as movement control nothing. I tried the process again with same result. I tried recalibration with same result. GIMBAL moves around at 1st of calibration and stops. I am amazed whoever the programmers in China are that they are not fully testing the product. Where can I download the old firmware version and see if that will fix the issue. This type of issue is avoidable and since half the reason to purchase a drone is taking pictures, this is unacceptable. Any suggestions??
 
Mine updated fine through the smart controller. I was a bit worried after seeing the posts about it but I have a spare so thought I would update one and see how it went. Evo 2 V3 RTK
 

Latest threads

Members online

Forum statistics

Threads
11,344
Messages
103,287
Members
10,036
Latest member
luke562