Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

No Live Display on Controller or App

micahmesser

Member
Joined
Sep 2, 2023
Messages
5
Reaction score
0
Age
30
Hello,

I just purchased the EVO II Pro direct from Autel. I received it yesterday, followed the instructions, downloaded the latest Autel Explorer V2 app, and charged everything up. I connected my phone to the controller, turned on the controller and then the drone. I was able to control everything but the camera from the drone refused to show on both the app and the controller when I disconnected the phone and pressed DISP. All that happens when I remove the phone and press DISP is a loading screen for the camera and nothing happens.

I have tried numerous power up and power off cycles. When I attempt to record or capture a picture, it also fails.

I contacted support but as one might expected, I have not received anything back from them.

Any assistance would be appreciated!
 

Attachments

  • 20230902_112028.jpg
    20230902_112028.jpg
    2.2 MB · Views: 1
  • Screenshot_20230902_112434_Autel Explorer V2.jpg
    Screenshot_20230902_112434_Autel Explorer V2.jpg
    324.4 KB · Views: 1
  • Screenshot_20230902_112728_Autel Explorer V2.jpg
    Screenshot_20230902_112728_Autel Explorer V2.jpg
    251.1 KB · Views: 0
  • Screenshot_20230902_114425_Autel Explorer V2.jpg
    Screenshot_20230902_114425_Autel Explorer V2.jpg
    256.6 KB · Views: 0
  • Screenshot_20230902_114432_Autel Explorer V2.jpg
    Screenshot_20230902_114432_Autel Explorer V2.jpg
    217.8 KB · Views: 0
  • Screenshot_20230902_114455_Autel Explorer V2.jpg
    Screenshot_20230902_114455_Autel Explorer V2.jpg
    255.8 KB · Views: 1
Last edited:
Check your cable and/or replace if necessary.
 
The cable wouldn't affect the controller, right? The controller doesn't even work.
 
The cable wouldn't affect the controller, right? The controller doesn't even work.
Yes, it could. Although most likely not the case, I would try ensuring the controller and drone are paired. Read how to pair in the manual.
 
Tried a different cable, no change. Paired the drone with the remote, no change.
 
Tried a different cable, no change. Paired the drone with the remote, no change.
Definitely a support submission to Autel. I know you stated that you have. Hopefully, they will get back to you soon. Please let us know what they say and what fixed your issue.
Sorry you have to go through this, I know it is frustrating.
 
First experience with Autel, not a good start. Since it is the weekend, I doubt I will get any resolution this weekend.

Should note, when trying to record or take a picture, it doesn't work either. Nothing gets stored on the SD card (tried several of those). Also, the obstacle avoidance would not turn off no matter what I tried. Lastly, when I tried adding the drone to "My Devices" under my profile it stated it couldn't find a serial number. I think there is something seriously wrong.
 
First experience with Autel, not a good start. Since it is the weekend, I doubt I will get any resolution this weekend.

Should note, when trying to record or take a picture, it doesn't work either. Nothing gets stored on the SD card (tried several of those). Also, the obstacle avoidance would not turn off no matter what I tried. Lastly, when I tried adding the drone to "My Devices" under my profile it stated it couldn't find a serial number. I think there is something seriously wrong.
I agree. There are too many things that are wrong. I own the Evo Lite Plus and love it. Although I just added the Air 3 to my fleet, the EVO Lite + is still my go-to drone.
Things go wrong with any manufacturer. Autel has been good at answering my questions so hopefully, they'll get back to you sooner than later.
 

Latest threads

Members online

Forum statistics

Threads
11,145
Messages
102,177
Members
9,698
Latest member
christine.reyna