Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

Evo2 doesn't work well and RC V1 doesn't connect with drone after firmware V2.7.47 update

exooll

New Member
Joined
Aug 13, 2023
Messages
3
Reaction score
0
Age
29
Hi, I updated my firmware after I noticed a notification in the app about firmware V2.7.47 is available. Everything went correct until the screen with upgraded components appeared on my remote controller. Device asked for rebooting RC and aircraft. I did it, on the screen appeared powering up and then connecting but from this time the RC has never connected with aircraft (but it still can send a video from camera to my app). My app still shows a new firmware is available to install but download button doesn't work because it informs "Aircraft low battery can not be upgraded" even if all my batteries are fully charged.

I've tried hundred times to pair RC and aircraft as well as reinstalling a firmware manually with SDcard (according to manual and Autel videos, step by step). Nothing works. I even tried to use downgrade my firmware but manual installing doesn't even begins (in all cases).

I also repeated everything with downgraded app to V1.2.11 but still no effects (originally I had the latest version).

Interestingly, that booting sound signal completely gone (sound known from booting aircraft /3 seconds on battery button/).

I'll be glad for help. I'm completely stuck.
 
Unfortunately it doesn't work. I try to launch the firmware reinstall with phone and without it, with connected phone with app and without an app, with the latest app version and with older one.

I don't know exactly how does the manual reinstall work so I don't even know can it begin if the remote controller still isn't able to connect with aircraft. And as I mentioned, the aircraft doesn't make that sound when you typically start the battery. It gives the impression that drone is stuck, but from the other side I can see the view from camera on my phone (inside the app in camera mode - for one second because the app takes me back to the previous view automatically). Another aspect is that if I still try to download the firmware upgrade, I receive the information about aircraft low battery (in fact it's full). I have 4 batteries and all are the same.

Screenshot_20230911-210920.jpg
Should anything appear on the RC screen if reinstall started succesfully? I have only the screen with the title RC is connecting, over and over. Even with this screen I'm waiting 45 minutes, even an hour, but nothing happens.
 
I also noticed different firmware versions during powering up and shut down.
 

Attachments

  • IMG_20230911_211938.jpg
    IMG_20230911_211938.jpg
    1.2 MB · Views: 7
  • IMG_20230911_212045.jpg
    IMG_20230911_212045.jpg
    1.8 MB · Views: 7
  • IMG_20230911_212057.jpg
    IMG_20230911_212057.jpg
    1.7 MB · Views: 7
Which remote do you have, V1 or V2 Standard RC or V1 Smart Controller. The V1 Standard Controller has orange on the back and the V2 has black on the back where the folding arms connect. Hope that helps, you may need to pair the remote with the quads pairing button on the side check the manuel
 

Latest threads

Members online

Forum statistics

Threads
11,145
Messages
102,177
Members
9,698
Latest member
christine.reyna