Welcome, Autel Pilots!
Join our free Autel drone community today!
Sign up

My "strange" experience with AUTEL support (never received a reply): (update: finally they replied; now waiting for fixing)

lukappaseidue

Well-Known Member
Joined
Oct 11, 2019
Messages
130
Reaction score
95
Age
47
Location
Catania, Sicily
Hi guys, I'm here to tell you about my experience or maybe I should say nightmare that I'm living with AUTEL support.
Day 23 June I received my long awaited AUTEL EVO II PRO 6K, purchased on BANGGOOD because it was the only place that allowed me not to wait too long.
After charging the batteries, I performed the firmware update, as per application notice.
For prudence I performed the update via SD on drone and started first drone and then radio control.
All done without any problem.
on the 24th I'm going to fly and just to know the behavior of both the drone and the wonderful camera, I start taking which photo and make some videos in AUTO SETTING mode.
The result has been disastrous.
The photos and videos blurred, especially on the right and lower right of the photo and on the video, but in general the overall quality is poor in all areas.
To be sure that my EVO II PRO was in trouble, I decided to take a flight in tandem with another EVO II PRO with the exact same settings of both the photos and the video and pointing the same subject. This test has allowed me to understand unequivocally that my room has a serious defect.
So on June 25 I contact the support via chat which, although, online, does not respond. Ok on the same day I send an email to [email protected] attaching immediately both the proof of purchase and the serial numbers of my drone and a couple of photos from which you can clearly see the defect.
I'm not getting any response. I try again from the support, this time offline, and ask to be contacted by entering my email, but nothing at all.
I create an entire shared folder, with some photos and videos and with the comparison with the other EVO II PRO to get a clear idea of the issue (just if it should be needed, given that the support surely knows its own product and knows how this must work ).
I redo new email and insert, also shared link. Nothing. I'm not getting an answer. I'm looking for CHAT to Dave, Taylor or Alejandro ... absolute silence.
to date, 29 June 2020 I have not yet received an answer.
I really don't understand why this silence.
I am really sad and disappointed by this behavior and above all by not knowing how to fix the problem of my camera.
P.S. Other friends of mine need to get in touch with support (for other info) and emailed them: and the soon received reply, even sunday 28 !!!!
What have I to do?

As far as regarding the attached pictures, the first is from my EVO II PRO, while the other is from the Maurizio EVO II PRO (that's as it had to be)
29 June 2020: Update: Finally Autel Robotics replied to my help request. it's already something. I hope that they fix this issue
InkedLUCA_bad_LI.jpg InkedLUCA_bad_LI.jpg InkedMAURIZIO_good_LI.jpg

 
Last edited:

Tufargon

Well-Known Member
Joined
Jun 3, 2017
Messages
1,816
Reaction score
847
Age
50
I've never known them to not respond. Maybe try calling them.
Toll-free: (844) MY AUTEL or (844) 692-8835
For customers located in New Zealand
Toll-free: +64 800 627010
 
  • Like
Reactions: lukappaseidue

Tufargon

Well-Known Member
Joined
Jun 3, 2017
Messages
1,816
Reaction score
847
Age
50
Did you look at the lens? I'm just throwing this out there but it has happened that people have forgotten to take off the plastic on it.
 

Tufargon

Well-Known Member
Joined
Jun 3, 2017
Messages
1,816
Reaction score
847
Age
50
I was not insinuating that you were a "noob" at all. I've seen long time professionals overlook that simple thing.
I would just call Autel at the number I posted above.
 
  • Like
Reactions: lukappaseidue

lukappaseidue

Well-Known Member
Joined
Oct 11, 2019
Messages
130
Reaction score
95
Age
47
Location
Catania, Sicily
I was not insinuating that you were a "noob" at all. I've seen long time professionals overlook that simple thing.
I would just call Autel at the number I posted above.
Excuse me dear friend, I didn't want to be misunderstood and I didn't want to be controversial.
I apologize if I gave you the idea of being one.
 
  • Like
Reactions: Tufargon

advexure

Well-Known Member
Approved Vendor
Joined
Jan 10, 2020
Messages
70
Reaction score
52
Website
advexure.com
Give Autel a call. They are very receptive and always extremely helpful by phone. "BANGGOOD" is not an authorized Autel dealer that we are aware of so you may run into warranty issues with your proof of purchase.

Seeing that you're in Italy, I'm not sure who your local dealers are, but have them assist you in resolving the issue with Autel as they have backend dealer support channel resources.

Best of luck on getting your issue swiftly resolved.
 
  • Like
Reactions: lukappaseidue

Madhungarian

Well-Known Member
Joined
Jan 14, 2019
Messages
424
Reaction score
205
Same sd card? What about video? Have you tried using the internal 8 gb storage and loading the image from there? I would check your propellers and make sure you do not have a similar issue like 808 had. Just a thought. How long did you wait for a response? I agree with consensus, call them, they are on Pacific Std time.
 
Last edited:
  • Like
Reactions: lukappaseidue

lukappaseidue

Well-Known Member
Joined
Oct 11, 2019
Messages
130
Reaction score
95
Age
47
Location
Catania, Sicily
Give Autel a call. They are very receptive and always extremely helpful by phone. "BANGGOOD" is not an authorized Autel dealer that we are aware of so you may run into warranty issues with your proof of purchase.

Seeing that you're in Italy, I'm not sure who your local dealers are, but have them assist you in resolving the issue with Autel as they have backend dealer support channel resources.

Best of luck on getting your issue swiftly resolved.
Thank you ver much friend. At the end, finally, AUTEL replied to me.
I assure you that this silence of the support has worn down my brain. But now, at least, I have had a signal. Hopefully they will solve my problem.
As for the purchase, the truth is that up to now, we Italians have no choice on the retailer. You may not remember, but I also contacted you, Advexure, to purchase EVO II. But before purchasing EVO II from banggood, I had contacted AUTEL support via chat to get information about the warranty and specifying that the seller was banggood, although it was not included in the authorized ones. I was not given an answer that I was able to keep (it was given to me via chat) but I was replied that AUTEL guarantees their products regardless of where it was purchased.
 

lukappaseidue

Well-Known Member
Joined
Oct 11, 2019
Messages
130
Reaction score
95
Age
47
Location
Catania, Sicily
Same sd card? What about video? Have you tried using the internal 8 gb storage and loading the image from there? I would check your propellers and make sure you do not have a similar issue like 808 had. Just a thought. How long did you wait for a response? I agree with consensus, call them, they are on Pacific Std time.
thank you for tips: I have done severals test, even using different HQ and faster speed MicroSD, but the result was always the same :(
 

Rubik3x

Well-Known Member
Joined
Nov 4, 2018
Messages
72
Reaction score
28
Location
Washington State
Since the blurry places are in the same location in each picture, it could be there is some grease on the lens cover. It could even be under (inside) the lens cover or on the curved lens itself. The lens cover unscrews but it might be tight. I would check these surfaces before sending the drone to Autel. Good luck.
 
  • Like
Reactions: lukappaseidue

lukappaseidue

Well-Known Member
Joined
Oct 11, 2019
Messages
130
Reaction score
95
Age
47
Location
Catania, Sicily
Since the blurry places are in the same location in each picture, it could be there is some grease on the lens cover. It could even be under (inside) the lens cover or on the curved lens itself. The lens cover unscrews but it might be tight. I would check these surfaces before sending the drone to Autel. Good luck.
I clean using isopropilic alcool. But nothing.
 
  • Like
Reactions: Rubik3x

Tomaso

Member
Joined
Apr 1, 2020
Messages
20
Reaction score
1
Age
69
Autel has always responded to my inquires in a timely manner. I agree you paid for an expensive funky camera. Perhaps the problem is communication. You should proof your emails. English is obviously not your 1st language. Perhaps your explanation of the problem wasn't understood.
 

lukappaseidue

Well-Known Member
Joined
Oct 11, 2019
Messages
130
Reaction score
95
Age
47
Location
Catania, Sicily
,

my name is Luca from Italy and I am your customer.

This is my AUTEL ID: l*****@****.it

After a very long wait from the presentation and therefore the wait for the purchase of EVO II 6K and finally the wait for the shipment, yesterday I finally received my long awaited and desired EVO II 6K.

However, I was very bitter and disappointed with what happened to me.

I received EVO II 6K on June 23, 2020.

After loading the batteries I perform the firmware update via SD which ends successfully.

Yesterday morning I take the first flight and some photos and videos to see the works of art that this 1-inch GIMBAL is able to take ... But the result has been disastrous and horrible and I am very disappointed.

The images are all blurry and in particular they are very blurry on the right area and also on the bottom right.

All settings set to AUTO

I reset the gimbal, reset the application settings (version 1.1.5.3 for Android)

I also noticed the jello effect (not very pronounced, but it is there) on some videos (even the videos are blurred and in particular on the right area and on the bottom right area)

it is clear that this is a not perfectly functional gimbal.

Please help me.

I would not want my AUTEL dream to turn into a nightmare.
 

Latest threads

Members online

Forum statistics

Threads
5,710
Messages
54,294
Members
3,823
Latest member
Spikemixture