Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

Is there a autel support? Cant connect to the drone after failed firmware


Nov 8, 2022
Reaction score
Last saturday the firmware upgrade failed for the first time since februari. Under the upgrade process I got a error message that "upgrade failed" and after that my Autel Nano + is not longer reachable at all. in the Autel Skyapp "Aircraft disconnected" is showed. Tried to uninstall and reinstall the app on two different devices without succes. Also tried the two ways to pair the Drone with the RC that describes on the web - no succes. The LED indicator on the drone flashes in yellow slowly (after the manual =Update fail)
Cant find and way to reset the Drone or download a firmware file and runt from the SD card

My questions
- is there a way to solve this? Tips!
- I wrote to [email protected] but no anser at all. Is there anyone really working with support or is the support just fake?
- Should I use some oher supportway?
I have had a response from Autel support usually within two days for some of the hiccups with my Autel drones. Regarding failed updates, that has happened, but they have been resolved by starting over from the beginning (including removing the app from the phone and reinstalling it). Try [email protected].
You may wish to review this firmware update thread. Firmware Update: NANO/NANO+ 1.2.14
I got firmware from Blade Strike, put it on microSD-card and it worked.
Thanks for answer. But after reading the long suggested thread I'm not really understand how to do ? Is Blade Strike in someway way a part of Autel support? And in wich way could I get/download the firmware files? And after that how to initial the upgrade from the SD-card ?
Thanks for answer and suggestion. After a mail to [email protected] I got a quick good response with a way to download the firmware to the SD Card of the aircraft. But no success, The aircraft is behaving the same way as it have done since the firmware upgrade hang/crashed .Yellow Led flashing slowly and still cant connect to the Aircraft in any way . The app is showing "Aircraft disconnected" , tried to reinstall the app also tried to reconnect the Aircraft following the two different methods in the manual, nothing worked. A double press on the Aircrafts batterybuttom results in nothing..
So the dialog with the support will be continued....or does anyone here got more ideas?
Update to this thread. After a very good mail conversation with [email protected] ([email protected] is a dead end) Traying to update the firmware from a firmwarefile that i got from Autel did not work, the aircraft was not able to connect at all. It ended up in sending the Aircraft and RC controller to the Autel support center in Germany...Now is waitingtime....
  • Like
Reactions: enKoDed
I bought extra drone on BF deal for under $500. Almost half of what our company paid for their 3 Nano + units a few months ago. I think the company is ordering a few more too given the price and bundles being as cheap (around $600 w 3 batts). We use these like crazy for everything. Some of our N+ batteries already have 60 to 70 charge cycles on them.

Latest threads

Members online

Forum statistics

Latest member