Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

First crash..this could have been much...MUCH worse.

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
I am breathing a HUGE sigh of relief tonight. I've been flying around downtown Philly for just over a month with no issues at all - I do avoid coming anywhere near the skyscrapers. So today I head down there took a brief flight to get overhead shots / video above the Ben Franklin Bridge (heads in NJ) - no problems as usual, I've taken this flight a few weeks ago from the same location...all was fine UNTIL today. I was coming in for a landing, suddenly 100ft out (50ft above) looking back at the the flight log I get this "Abnormal Compass" - switch to ATTI to avoid interference "....which I did but no response at all...it sat hovering for 1, 2 seconds, then briefly wobbling back and forth violently, circled then dropped like a rock into the cobblestone street. Missed parked cars, no cars driving down this non-busy side street, and no people. Can't stress this enough, ...forget the drone, all I can say is I'm thankful this goofy issue happened where it did! (I have extremely busy Interstate 95 just 200 feet to my east, a busy bridge a block to the south, major crosstown freeway literally behind me to my north..this could have been horrific!)

So 1st crash now in the books..no one hurt - of course my heart dropped, I run over expecting pieces all of the place and I hear this grinding noise. Heres the drone is upside down as the propellers were still in full power rotating, grinding into the street. Doing everything in my power trying to kill the power with failsafe - no luck shutting this thing off. Now in a slight panic I grab one of the landing legs to get it off the ground to prevent killing the motors. I know..maybe not too smart. As I did, it literally jerked my right arm me since its still on fully power..yes the propeller got me in the arm. ( Not pretty..but I'll be fine. And THAT could have been much worse too!) FINALLY the ATTI kicks in and I'm able to shut the darn thing off with the RC failsafe "kill mode."

Now I'm inspecting it - I know I look like a disheveled mess.. my arm looks like I was attacked by Wolverine, literally 3 swipes..ugh. I'm shocked, the drone is fine, shell has no scratches at all...the propellers, no that's another story. Those are a mess, the colored tips literally shaved down. It took effort, use of the tool to remove them since the grinding really tightened them up. I drive home, clean up my arm..BUT I do want to see if this X Star is ok. Took it to the park a few blocks away..broke open the spare propellers they give us, it seems fine, camera, gimbal is ok. No problems with the RC connection.

So..I have no idea what the heck happened and I feel a little dumb tonight, lucky but dumb! Abnormal compass is a first, ATTI is not, it's happened 2 times already and thankfully I'm ok with complete manual flying after 6 weeks..but having it not respond what so ever, that's new. Back to how this drone is made..I'm stunned. When this thing dropped, I expected to see it in pieces!

Flight Log from my app, final 40 seconds.
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
Yeah it did! Glad it still works though. No problems early this morning....flawless flight. Something in that area really goofed the drone up.
 

DroneDriver

Well-Known Member
Joined
Mar 2, 2017
Messages
186
Reaction score
71
Location
Northern DE
Wow ACJ,
What a story! I am just down the road a bit in N. DE and I have never had that happen. Granted, we live in the rust belt and Philly has a lot of metal. What did Autel say? Did they review the log? I guess after the three slashes and the bloodletting, your drone is ready to join the Xmen.
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
Wow ACJ,
What a story! I am just down the road a bit in N. DE and I have never had that happen. Granted, we live in the rust belt and Philly has a lot of metal. What did Autel say? Did they review the log? I guess after the three slashes and the bloodletting, your drone is ready to join the Xmen.

No, but I have to call them this afternoon, it looks like I didn't escape damage to the XSP...I noticed it last night, then took a brief flight with video about 1 hr ago and the gimbal seems to be out of whack. I have no idea if it's something I can fix..if something is loose. No idea.

It's level when I start the flight, I'll gain altitude..but as soon as I start to turn...the camera tilts, it will slowly auto correct itself to some degree. It just doesn't appear to be level with the horizon. I checked the settings, gimbal is "stabilized," I adjusted the roll but that doesn't make a difference. ugh.
I know it could be worse, the whole camera - the entire drone - could have been destroyed. Still...it's a tad deflating right now. :(

 

kcult

Member
Joined
Apr 24, 2017
Messages
9
Reaction score
3
Location
NE SC
It does look like the horizon is lower on the left side, but I'll admit to not having an experienced eye.

Sorry about your crash, too. I crashed mine in a neighbor's tree. It fell about 25ft. The crash broke two props, ripped the camera from the gimbal and cracked one arm. After putting it all back together, the only obvious problem is the LED on the cracked arm doesn't work. I took it apart to find the connector was dislodged from the main board. I can live with that since everything else works.
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
It does look like the horizon is lower on the left side, but I'll admit to not having an experienced eye.

Sorry about your crash, too. I crashed mine in a neighbor's tree. It fell about 25ft. The crash broke two props, ripped the camera from the gimbal and cracked one arm. After putting it all back together, the only obvious problem is the LED on the cracked arm doesn't work. I took it apart to find the connector was dislodged from the main board. I can live with that since everything else works.

Eck. Sorry! I know we have to expect a possible crash - eventually, it just makes your heart drop when it happens, especially that first crash. I have to ship mine back to Autel, not even sure if it's the gimbal and / or one of the prop motors now. I removed the entire gimbal and put it back on, I took it up again briefly last night and the horizon looked ok actually...briefly. It went back to this tilt issue (yeah the horizon is much lower on the left, also happens on the right - left tilt seems worse). Also it was extremely erratic as it hovered at 10-15 feet - no wind at all, I quickly landed it. I checked the props - 3 I could easily remove but the one with a slight nick on it from the darn crash I couldn't remove the propeller with my fingers, it seemed that it really tightened up after the brief flight...that motor felt hotter that usual also. Only able to remove it using the wrench provided. Eh, so I have to get this fixed..I just can't trust it right now to fly it.
 

David Myers

Active Member
Joined
Nov 13, 2016
Messages
29
Reaction score
15
Age
65
No, but I have to call them this afternoon, it looks like I didn't escape damage to the XSP...I noticed it last night, then took a brief flight with video about 1 hr ago and the gimbal seems to be out of whack. I have no idea if it's something I can fix..if something is loose. No idea.

It's level when I start the flight, I'll gain altitude..but as soon as I start to turn...the camera tilts, it will slowly auto correct itself to some degree. It just doesn't appear to be level with the horizon. I checked the settings, gimbal is "stabilized," I adjusted the roll but that doesn't make a difference. ugh.
I know it could be worse, the whole camera - the entire drone - could have been destroyed. Still...it's a tad deflating right now. :(

I read your post this morning and after looking at some of my footage wanted to let you know my camera does the same thing and it has never been crashed. The tilt in your footage seemed to start with a yaw move and then stabilize. Same with my camera but not quite to the degree of yours.

I am running firmware version 1.2.8, are you running on the same? This firmware I believe has a smoother yaw but I'm speculating that it may cause the problem you and I both seem to have.

The link below is an example of my camera.

Horizon Clip.mov
 
Last edited:

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
I read your post this morning and after looking at some of my footage wanted to let you know my camera does the same thing and it has never been crashed. The tilt in your footage seemed to start with a yaw move and then stabilize. Same with my camera but not quite to the degree of yours.

I am running firmware version 1.2.8, are you running on the same? This firmware I believe has a smoother yaw but I'm speculating that it may cause the problem you and I both seem to have.

The link below is an example of my camera.

Horizon Clip.mov

I have version 1.1.3 firmware.

Wow I see that, I've noticed this very slight tilt issue every since I bought it on April 4. With the help from this forum, I went into gimbal roll settings and had to set this around -0.6, -0.8, that solved that problem, but it always kind of bugged me.
After the crash it really goofed things up, similar to your video.

Odd, I'm not an expert at any of this and really have no idea what is causing the problem..it's appears ok when your flying forward towards the SW, once you start to yaw 180º towards the NE, yep I see that tilt..but now you're also getting more of the ground, less sky (No pitching down the camera) - as the entire drone itself is now facing NE. (hope that makes sense? lol) I just can't quite figure out if one of the rotors is causing some un-level horizon issues AND / OR gimbal. That part was driving me nuts and no gimbal roll adjust was fixing that. I let Autel know that I had this gimbal roll issue from day one

pwBXtfz.jpg



Anyway, I finally got a shipping label and RMA number this morning in from Autel. Asked me to ship back the drone and RC in the hard case (nothing else). I dropped it off at FedEx a few hours ago. Sooner I ship it out, sooner I get it back :)
So it will probably take about 5-7 days from Monday to get to Washington, then the disclaimer - "the evaluation, repair and shipping procedure can take our techs up to 14 days to complete."

That's fine, as long as this gets fixed.

EDIT: Not that it matters for me right now, just wondering where is this firmware 1.2.8?
I still see the 1.1.3 on their site, that's the same file I downloaded and installed back on April 4.
Downloads | Autel Robotics
 

David Myers

Active Member
Joined
Nov 13, 2016
Messages
29
Reaction score
15
Age
65
I have version 1.1.3 firmware.

Wow I see that, I've noticed this very slight tilt issue every since I bought it on April 4. With the help from this forum, I went into gimbal roll settings and had to set this around -0.6, -0.8, that solved that problem, but it always kind of bugged me.
After the crash it really goofed things up, similar to your video.

Odd, I'm not an expert at any of this and really have no idea what is causing the problem..it's appears ok when your flying forward towards the SW, once you start to yaw 180º towards the NE, yep I see that tilt..but now you're also getting more of the ground, less sky (No pitching down the camera) - as the entire drone itself is now facing NE. (hope that makes sense? lol) I just can't quite figure out if one of the rotors is causing some un-level horizon issues AND / OR gimbal. That part was driving me nuts and no gimbal roll adjust was fixing that. I let Autel know that I had this gimbal roll issue from day one

pwBXtfz.jpg



Anyway, I finally got a shipping label and RMA number this morning in from Autel. Asked me to ship back the drone and RC in the hard case (nothing else). I dropped it off at FedEx a few hours ago. Sooner I ship it out, sooner I get it back :)
So it will probably take about 5-7 days from Monday to get to Washington, then the disclaimer - "the evaluation, repair and shipping procedure can take our techs up to 14 days to complete."

That's fine, as long as this gets fixed.

EDIT: Not that it matters for me right now, just wondering where is this firmware 1.2.8?
I still see the 1.1.3 on their site, that's the same file I downloaded and installed back on April 4.
Downloads | Autel Robotics
The 1.2.8 firmware is not available on their site. My bird came with it installed and I never updated. When the new firmware comes out I will update. If you google autel 1.2.8 firmware you can find a copy on a user's site.
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
FINALLY got the X-Star back this morning, did a quick test flight and all is well again. The "Aircraft Main PCB" needed to be replaced.

Admit I was a tad worried that this wouldn't fix my initial gimbal titt issue - I even called to ask if this would fix it and got a reply, "it should."
Anyway, what do I know. :) So that tilt issue is gone thankfully Just glad to have it back, it's only been 3 weeks and 5 days without it, it seriously feels like 3+ months! :confused:

Now the ONE thing I can't seem to get working is the Firmware install. I downloaded the 1.13 from the site, I tried 4 times with all "failed" messages
It finally loaded the gimbal firmware portion, but it actually looked like it downgraded that from to Ver. 2.0.3.3 to 2.0.1.7, odd.

Sonar or Optical Flow just fails to update.
Right now I have Sonar - ver 0.0.9.5, Optical Flow is ver. 0.6.4.0

(update)

The 1.2.8 firmware is not available on their site. - - - If you google autel 1.2.8 firmware you can find a copy on a user's site.
Oh and forgot about this, I found that 1.2.8 firmware file. So I'm gonna give that a shot. Thanks for the tip!
 
Last edited:

David Myers

Active Member
Joined
Nov 13, 2016
Messages
29
Reaction score
15
Age
65
Glad to hear that all is well and I'm sure you will be in the air often after the long lay-off.
 

Agustine

Well-Known Member
Joined
Jan 18, 2017
Messages
6,824
Reaction score
5,244
Age
64
Location
Northern Ontario
Your bird was probably already up to date. Thats is why it kepts saying failed. As for trying to put 1.2.8 it cannot be done. Trust me I have tried and even talked to Autel support but it is a no go.

Sent from my LG-D852 using Tapatalk
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
Your bird was probably already up to date. Thats is why it kepts saying failed. As for trying to put 1.2.8 it cannot be done. Trust me I have tried and even talked to Autel support but it is a no go.

Sent from my LG-D852 using Tapatalk

Cool, thanks! Yeah I decided not to even attempt the 1.2.8, it was tempting seeing that it improves the jittery yaw, but I saw some had other problems - so I wasn't going to risk any possible issues. I guess that is all moot anyway. :)
Just wait for the official new Firmware from Autel...hopefully soon! Thanks again.
 

Banaszak40

Member
Joined
Jul 17, 2017
Messages
5
Reaction score
0
Age
34
Did they replace your camera? Or are they trying to say that replacing your aircrafts main pcb fixed the tilt issue? I'm confused.
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
Did they replace your camera? Or are they trying to say that replacing your aircrafts main pcb fixed the tilt issue? I'm confused.
No, they replaced the Aircraft Main PCB, this fixed the severe gimbal tilt, "floating" issue I had.
Still have the original camera on there.
 

Banaszak40

Member
Joined
Jul 17, 2017
Messages
5
Reaction score
0
Age
34
I crashed my drone, Camera has been floating and swaying like crazy! it does it even if i set it it on a flat table and don't even touch the drone. I am sending it back today for repair. Im surprised something on the aircraft has to do with this? does this sound similar to what you were experiencing? My drone flies great, hovers, gets to 33mph. Hopefully they can do the same with mine!
 

ACJunior

Well-Known Member
Joined
Apr 9, 2017
Messages
83
Reaction score
22
Age
48
Location
Jenkintown, PA
I crashed my drone, Camera has been floating and swaying like crazy! it does it even if i set it it on a flat table and don't even touch the drone. I am sending it back today for repair. Im surprised something on the aircraft has to do with this? does this sound similar to what you were experiencing? My drone flies great, hovers, gets to 33mph. Hopefully they can do the same with mine!

Yeah, it's similar. I had no problems with flight after the crash, the next day when I took it up for a test it looked ok...for about 10 seconds. Then I noticed the camera was all over the place. It seemed like it would try to "correct" itself, but it would then go haywire again anytime I yawed, horizon seemed to be lower if I faced once direction, higher in the other. I thought it had to be the camera, but I guess not. (I did have to return it back to Autel a week after I got it back, the one motor that took the brunt of the crash in May seemed to finally die.) Got it back Friday...so far so good. **KNOCK ON WOOD!* :)

This is the video of the tilt issue I showed Autel back in May.
 

Latest threads

Forum statistics

Threads
8,097
Messages
76,419
Members
5,973
Latest member
socializedNerd