Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

Remote and phone connectivity issues

Dariobs

Member
Joined
Sep 22, 2020
Messages
11
Reaction score
11
Location
Sydney, Australia
Hi all, I got my Evo2Pro since October last year and it's been amazing so far. However, a couple of days ago, I was flying it and the control remote and phone got disconnected. Battery in both was over 70%, there was a direct sight and good signal overall.
Luckily I was able to return the drone home and there was no damages.

For the last couple of days I've tried different USB cables, reinstalled the phone app and even used another android phone to see if the issue was with the phone. Unfortunately, none of these actions/tests returned a positive result - I am still unable to connect the remote to my phone.

I am running the latest version on the phone app, controller, drone and batteries. And this started to happen all of a sudden mid-flight.

I wanted to see if anyone in this forum has experienced some similar issues with the E2P and how they got fixed, and/or alternatively if you can point me to the best contact number/email address to notify the customer service and proceed with a troubleshooting (I am based in Sydney, Australia)

Thanks so much for your help.
Dario
 

gschulzuio

Well-Known Member
Joined
Dec 14, 2020
Messages
260
Reaction score
116
Is your phone in airplane mode? If not, try that and see if things improve. Also check your antenna config, they should be up and pointing towards aircraft and not crossed or pointing towards each other. If aircraft is more overhead, try flipping one of the antenna to be flat and point upwards.
 

Dariobs

Member
Joined
Sep 22, 2020
Messages
11
Reaction score
11
Location
Sydney, Australia
Is your phone in airplane mode? If not, try that and see if things improve. Also check your antenna config, they should be up and pointing towards aircraft and not crossed or pointing towards each other. If aircraft is more overhead, try flipping one of the antenna to be flat and point upwards.
Thanks mate, yep all of that was considered.

Also, please mind the issue is with the connection between phone and controller. Connectivity with the drone itself is good, as I was able to pilot and control it with the controller (without the phone).
 

gschulzuio

Well-Known Member
Joined
Dec 14, 2020
Messages
260
Reaction score
116
Thanks mate, yep all of that was considered.

Also, please mind the issue is with the connection between phone and controller. Connectivity with the drone itself is good, as I was able to pilot and control it with the controller (without the phone).
No worries, I had seen some issues when have phone wifi or cell on, have turned off and eliminated some issues. Otoh could be a bad cable.
 

Brock Inspector

Well-Known Member
Joined
Jan 18, 2021
Messages
151
Reaction score
91
Age
61
Try another USB cable, using the USB-A port if you haven't already. What phone model and version of iOS or Android, what firmware and what version of Autel Explorer would be useful info too.
 
  • Like
Reactions: gschulzuio

Dariobs

Member
Joined
Sep 22, 2020
Messages
11
Reaction score
11
Location
Sydney, Australia
Hi all, I have not found the reason why this happened, but it seemed to be a one-off kind of issue.
I've consumed 3 full batteries over the last few days and no issues identified - using same phone, firmware versions, cable and controller.

I'll keep you all posted if this happens again.

Thanks for your recommendations and have a great week!
Dario
 
  • Like
Reactions: gschulzuio

Chaz

New Member
Joined
Jul 13, 2020
Messages
4
Reaction score
1
Age
40
It's happening to me too and I can't figure it out. Pixel 3 XL phone.
 

Dariobs

Member
Joined
Sep 22, 2020
Messages
11
Reaction score
11
Location
Sydney, Australia
Sorry to read that Chaz, it hasn't happened to me again, however I've recently upgraded my phone.
Unsure if the issue was related to my old phone/USB port Samsung s10
 

MCss454

Member
Joined
Apr 11, 2021
Messages
11
Reaction score
12
Age
59
I had the same issue the other day when out flying. Controller still worked but lost connection to the phone. Shutdown the entire system and restarted went fine after that. Had Do Not Disturb and Airplane mode turned on. Turned off the "do not disturb" and no further issues so far.
 

calvinchen

Member
Joined
Jul 5, 2021
Messages
7
Reaction score
1
Age
28
Hi all, I got my Evo2Pro since October last year and it's been amazing so far. However, a couple of days ago, I was flying it and the control remote and phone got disconnected. Battery in both was over 70%, there was a direct sight and good signal overall.
Luckily I was able to return the drone home and there was no damages.

For the last couple of days I've tried different USB cables, reinstalled the phone app and even used another android phone to see if the issue was with the phone. Unfortunately, none of these actions/tests returned a positive result - I am still unable to connect the remote to my phone.

I am running the latest version on the phone app, controller, drone and batteries. And this started to happen all of a sudden mid-flight.

I wanted to see if anyone in this forum has experienced some similar issues with the E2P and how they got fixed, and/or alternatively if you can point me to the best contact number/email address to notify the customer service and proceed with a troubleshooting (I am based in Sydney, Australia)

Thanks so much for your help.
Dario
i had the exactly same issue with u, buy the drone 19 Feb 2021, Problem happen date 20 April 2021, suddenly, till 4 July 2021, have been put away someplace few month, and yesternight update to the newest warefirm and reinstall the ios newest app, can use one time, today went outside home, turn on few minutes only, disconnect from controller and drone again, have read another post few user met this same situations, want to know how to solve it.
 
Last edited:

Chaz

New Member
Joined
Jul 13, 2020
Messages
4
Reaction score
1
Age
40
I finally fixed it by switching cables. I had already don this, but this time I used a cable that was usb (remote side) to usb c (phone side) and it has not happened again.
 
  • Like
Reactions: UasDriver

calvinchen

Member
Joined
Jul 5, 2021
Messages
7
Reaction score
1
Age
28
I finally fixed it by switching cables. I had already don this, but this time I used a cable that was usb (remote side) to usb c (phone side) and it has not happened again.
great to hear that, now im order new cable to give it a try, hope will work
 

Thermo

Member
Joined
Jun 12, 2021
Messages
7
Reaction score
11
Age
53
Hi, I had the exact same issue yesterday while flying a polygon mapping mission with my iPad mini and EVO II. During the auto flight, I continually received the voice message, "Aircraft & Remote Control Disconnected," "Home Point has been Reset," and "Mobile Phone & Remote Control Disconnected." Since the aircraft appeared to be following the route I let the aircraft continue the mission. However, during this mission and the 2 previous missions, the aircraft position and locations of photos froze on the iPad. The USB cable connecting the iPad to the controller is the same one that I used the same day with a Phantom 4, so I don't believe it was a cable issue. Has anyone figured this out? I certainly feels like a software glitch, however it is not repeatable.
 

Lefty01

Member
Joined
Feb 28, 2021
Messages
13
Reaction score
0
Age
50
Hi , Im also having the same problems . I using a Ipad Air 2 and I can go out around 4000ft then the signal goes to nothing but GPS is on full Bar . It comes up as weak signal and screen go's grey and the controller beeps and says lost connection to drone and it might take 30 secs to reconnect . By that time the drone is heading home . The sad thing is a old DJI Mavic 1 is twice as far with zero problems.
 

MikeTheEbike

New Member
Joined
Aug 1, 2021
Messages
1
Reaction score
0
Age
60
Hi, have same problems. Use as video screen a Samsung Galaxy S10 5G or an iPad 12.9" and have since last update problems from time to time with both. In one case I was 1km away over sea and home button helped me. In other case could fly home by sight. Did not change any hardware and use a high quality cable USB-A to USB C from a Nvidia development kit. Run with the cable which i use for flying a 8TB SSD for storing all clips. I assume a software issue ....
 

Latest threads

Members online

Forum statistics

Threads
8,049
Messages
75,904
Members
5,925
Latest member
LCummings99