Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

Replaced gimbal, no roll but from remote

slozukimc

Active Member
Joined
Jul 5, 2023
Messages
36
Reaction score
6
Age
54
I replaced a broken gimbal on an Evo. Everything seems fine except there is no roll control from the remote.

Any ideas?
 
Difficult to troubleshoot since the drone experience a crash or some such. Any substructure or electronics could have been compromised as a result. Wishing it were as simple as pulling off the camera and cleaning the ribbon cable contacts and trying again.
 
Difficult to troubleshoot since the drone experience a crash or some such. Any substructure or electronics could have been compromised as a result. Wishing it were as simple as pulling off the camera and cleaning the ribbon cable contacts and trying again.
Right! I don’t think it is an issue with a connection because the gimbal goes through all of the motions it should on startup and works perfectly fine when the drone moves.
 
I replaced a broken gimbal on an Evo. Everything seems fine except there is no roll control from the remote.

Any ideas?
I have that same problem, I just changed the flexible roll of the gimbal and it goes crazy and doesn't calibrate, and now it sends me a magnetic interference message
 
I have that same problem, I just changed the flexible roll of the gimbal and it goes crazy and doesn't calibrate, and now it sends me a magnetic interference message
Doesn’t sound like the same problem at all…….
 

Latest threads

Members online

Forum statistics

Threads
11,145
Messages
102,177
Members
9,698
Latest member
christine.reyna