Welcome, Autel Pilots!
Join our free Autel drone community today!
Join Us

Firmware Woes


New Member
May 27, 2023
Reaction score
Yes, another thread about firmware issues - after a firmware update, my remote will no longer connect to the drone.

-Everything was functional prior to the firmware update

- I initially used an OTA update
- The update continued and the remote indicated that everything was installed successfully. The remote prompted me to restart both the drone and the remote.
- After the restart, the remote will not connect to the drone. All 4 lights are slow-blinking simultaneously: front 2 are amber, rear 2 are red.
- After the restart, I could view a camera feed through my phone, which was successfully paired with the remote.

I have tried:
  • Resetting both the remote and drone
    • No change
  • Manually pairing the remote and drone
    • I pressed the pairing button located on the side of the drone until it rapid-blinked green. I then rebooted the remote, holding the home and power buttons. The remote booted up and displayed "Matching..." for several seconds, then went back to "Connecting..."
  • Downloading the firmware to an SD card
    • The V3 firmware (V1.1.9 ; 1/16/23) downloaded as a .ZIP file with 3 .BIN files and a .JSON file. I extracted all and put them into the root directory of the SD card. After inserting the SD card into the drone, I powered it on, and left to sit for 30 min. I removed the SD card and all the files are still viewable on the SD card.
I have tried searching for other solutions on the forums, but have not found anything. Any help would be appreciated.

Latest threads

Members online

No members online now.

Forum statistics

Latest member