Welcome, Autel Pilots!
Join our free Autel drone community today!
Sign up

Did you know your gimbal can point backwards?

Autelguy

Well-Known Member
Joined
Feb 1, 2018
Messages
179
Reaction score
98
Age
55
Hi Guys,

I wanted to share my story with you in hopes that it might help with similar problems I've seen reported.

My wife bought me an Autel Evo on Saturday 2/2/2019. Yeah, she's a sweetheart. We bought it from Best Buy and got a great deal which included the On-The-Go Bundle and a $100 Gift Card. BTW, Best Buy now matches Amazon prices. No store carries the On-The-Go Bundle so you have to either have it shipped to a store. or have it mailed to you.

I got home and charged my Battery #1 which came with the Evo and the controller. I was prompted for the latest FW update and everything went smoothly.

I had my maiden flight two days later and fell in love. I kept my first flight safe, very close and short.

A few days later, I got an email saying my On-The-Go Bundle was ready for pick from the store. I drove to Best Buy, got my bundle, went home and starting charging. Battery #2 charged just fine. I then proceeded to charge Battery #3. After about an hour, I saw that the 4th light on the battery was blinking. I unplugged it from the charger and let the battery rest. The charger felt warm but nothing that concerned me considering I was charging batteries back to back. I looked at the instruction pamphlet that came with the battery and noticed that the 4th light blinking indicated a Discharge Problem. I then plugged Battery #3 back into the charger and got no lights, indicating it was fully charged. Weird huh?

I started with Battery #1 and inserted it into my Evo so that I could take a picture of the battery serial number and to check the firmware version which read V1.1.6.0. I'm going to keep a spreadsheet of how many cycles I can get from all my batteries. Everything worked perfectly. The gimbal performed her dance but noticed there was a "tick" sound as the camera swung to the left and right. As if to hit a stop. I've seen a lot of unboxing videos and had seen and heard that tick sound before so I considered it normal.

I powered down the Evo, Controller and App then removed the battery. I then inserted Battery #2 and everything worked perfect just like Battery #1. I snapped a photo of that battery serial number the the firmware version was the same. Someone had posted a misleading video stating that you had to update the firmware on the batteries as well so considering Battery #2 and #3 were new and not part of my initial firmware update, they made need an update. The reality is that no battery firmware updates have ever been released for the Evo.

I then powered down the Evo, Controller and App. I removed Battery #2 and inserted Battery #3.

Upon doing so, the gimbal dance went fine and I was able to get into the app. I navigated to Setting then Battery info when all of a sudden the Controller read, App Disconnected. Three seconds later the controller read... App Connected. It did this multiple times. While this was happening I took a look at the USB cable thinking that maybe there was a short. But it was brand spanking new. I managed to get to the battery info screen and photographed the serial number and the FW version which was the same. As I was about to power down, then the controller suddenly read "Magnetic Interference" then the app displayed a gimbal calibration warning. At this point I just shut everything down.

Bad battery right? Keep in mind that I hadn't moved the Evo and both the Evo and controller were on the floor about 2 feet from each other. To test, I then inserted Battery #1 and fired everything up. Perfect. No app disconnect then re-connect, no magnetic interference, no gimbal warning - nothing. I then powered down then inserted Battery #2. Same thing, perfect. No problems.

I then inserted Battery #3 and experienced the same issues. App disconnects, re-connects then eventual Magnetic Interference warning on the controller as well as gimbal calibration warning on the app. I powered down and inserted Battery #1 and no problems. I then tried Battery #2 - no problem. I then tried Battery #3 one last time and had all the same issues.

The following day I called Autel Robotics and explained what was going on. They said what I was describing was very, very strange. They said they were going to ship me a new battery and to please send Battery #3 back to them for inspection. I asked if I should perform a gimbal and compass calibration and they said no. To never perform any calibration unless instructed to do so by the app - even after a firmware update. That doing so could lead to other problems.

The following day, the skies cleared and decided to take her for my second spin. Perfect conditions with 16 sats and fully charged topped off Battey #1 and controller. What you're about to see is very odd. Since there is no audio, let me explain what's taking place in the video. I took off facing me and noticed that the horizon looked skewed against my roof line. I saw a YouTube video that said we can now adjust the Gimbal Roll Axis. I got to about the roof line of my house, hovered and entered that setting within the app. I tapped on the left then the right to adjust the axis but wasn't sure if I was getting a true representation of a centered horizon. I then yawed my Evo facing away from me and gained some altitude to see the actual horizon. I tapped to the roll axis to the left when I noticed I was tapping in the wrong direction then tapped to the right. I over compensated then tapped on the left. When I thought I had everything centered, I tapped out of Settings then my gimbal suddenly dropped. I couldn't figure out was going on so I attempted to roll the gimabl up but no joy, it wouldn't budge up. I rolled the gimbal down and realized that I was now looking behind my Evo! I thought only porn stars could do that!

I tried to roll up again and it wouldn't move past facing straight down. I then decided to obviously land. As I was doing so, about 3 feet off the ground, I yawed back so that the front of the Evo was facing me. Right then, my gimbal tilted sideways and remained that way till I landed.

I powered everything off, checked the gimbal and everything looked fine. I powered up controller then Evo and app and the gimbal performed its usual dance. I took off and had no problems. No compass or gimbal calibration prompts, nothing. It was perfect short test flight. I then landed, powered off then powered on then flew again without any more problems. The following day I reached out to Autel and showed them the video of the flight. They claimed they had never seen anything like that. That since I had the Evo for only about a week, to take it back to Best Buy and get it replaced. I did that two nights ago and am looking forward to flying my "newer" Evo.

Check out the video:

In conclusion, my gut is telling me that I experienced two separate problems. The first was the battery. I've seen others report issues with sudden magnetic interference issues and app disconnects and re-coonects. I can safely say that those errors are were probably due to a bad battery which is causing anomalous errors within the app and controller software.

I believe the gimbal issue was possibly due to trying to adjust the gimbal roll axis in midflight and tapping on extremes (roll axis all the way to the left then right) which cause the gimbal software to "run home to momma" and give up. It obviously didn't loose power since I was able to record the whole event. I'd ask some of you to try to replicate what I did using gimbal roll axis during flight, but I don't want you to damage your gimbal by trying it. I would love to know for sure what caused this in-flight malfunction and isolate the issue. One thing is certain, if there is a problem with gimbal roll axis in mid-flight, we all need to know about it.

Lastly, after watching the video I noticed a strange gimbal movement right after playing with the gimbal roll axis while it was pointing at my roof. Something I didn't notice since I was in the Setting menu during the flight.

Guys - sorry for the long *** story and all the minute details but hopefully my event will go a long way in helping someone else out.

All in all, Autel was wonderful in addressing my concerns and provided the excellent support they're known for.

Wish me luck on my next maiden flight. Hey at least I got to peel the plastic film off two Evos - how many people do you know that can make that same claim :)

Tight lines and smooth flights ~
 
Last edited:

Agustine

Moderator
Staff member
Joined
Jan 18, 2017
Messages
4,188
Reaction score
2,421
Location
Northern Ontario
Great write up and thanks for posting that video. Never have I heard or seen that problem before on any UAV LOL
 
  • Like
Reactions: Autelguy

Ansia

Well-Known Member
Joined
Jan 10, 2019
Messages
1,024
Reaction score
514
2 things.

1) Now we know that the Mars Rover isn't the only machine that can take selfies.

2) You need to speak with your neighbors about getting different colored cars. There is more to this world than gray and white cars. *insert laughing emoji here*

I really enjoyed your story. You should consider becoming a novelist.
 

snow86man

Well-Known Member
Joined
Jan 19, 2019
Messages
53
Reaction score
40
Age
38
Hi Guys,

I wanted to share my story with you in hopes that it might help with similar problems I've seen reported.

My wife bought me an Autel Evo on Saturday 2/2/2019. Yeah, she's a sweetheart. We bought it from Best Buy and got a great deal which included the On-The-Go Bundle and a $100 Gift Card. BTW, Best Buy now matches Amazon prices. No store carries the On-The-Go Bundle so you have to either have it shipped to a store. or have it mailed to you.

I got home and charged my Battery #1 which came with the Evo and the controller. I was prompted for the latest FW update and everything went smoothly.

I had my maiden flight two days later and fell in love. I kept my first flight safe, very close and short.

A few days later, I got an email saying my On-The-Go Bundle was ready for pick from the store. I drove to Best Buy, got my bundle, went home and starting charging. Battery #2 charged just fine. I then proceeded to charge Battery #3. After about an hour, I saw that the 4th light on the battery was blinking. I unplugged it from the charger and let the battery rest. The charger felt warm but nothing that concerned me considering I was charging batteries back to back. I looked at the instruction pamphlet that came with the battery and noticed that the 4th light blinking indicated a Discharge Problem. I then plugged Battery #3 back into the charger and got no lights, indicating it was fully charged. Weird huh?

I started with Battery #1 and inserted it into my Evo so that I could take a picture of the battery serial number and to check the firmware version which read V1.1.6.0. I'm going to keep a spreadsheet of how many cycles I can get from all my batteries. Everything worked perfectly. The gimbal performed her dance but noticed there was a "tick" sound as the camera swung to the left and right. As if to hit a stop. I've seen a lot of unboxing videos and had seen and heard that tick sound before so I considered it normal.

I powered down the Evo, Controller and App then removed the battery. I then inserted Battery #2 and everything worked perfect just like Battery #1. I snapped a photo of that battery serial number the the firmware version was the same. Someone had posted a misleading video stating that you had to update the firmware on the batteries as well so considering Battery #2 and #3 were new and not part of my initial firmware update, they made need an update. The reality is that no battery firmware updates have ever been released for the Evo.

I then powered down the Evo, Controller and App. I removed Battery #2 and inserted Battery #3.

Upon doing so, the gimbal dance went fine and I was able to get into the app. I navigated to Setting then Battery info when all of a sudden the Controller read, App Disconnected. Three seconds later the controller read... App Connected. It did this multiple times. While this was happening I took a look at the USB cable thinking that maybe there was a short. But it was brand spanking new. I managed to get to the battery info screen and photographed the serial number and the FW version which was the same. As I was about to power down, then the controller suddenly read "Magnetic Interference" then the app displayed a gimbal calibration warning. At this point I just shut everything down.

Bad battery right? Keep in mind that I hadn't moved the Evo and both the Evo and controller were on the floor about 2 feet from each other. To test, I then inserted Battery #1 and fired everything up. Perfect. No app disconnect then re-connect, no magnetic interference, no gimbal warning - nothing. I then powered down then inserted Battery #2. Same thing, perfect. No problems.

I then inserted Battery #3 and experienced the same issues. App disconnects, re-connects then eventual Magnetic Interference warning on the controller as well as gimbal calibration warning on the app. I powered down and inserted Battery #1 and no problems. I then tried Battery #2 - no problem. I then tried Battery #3 one last time and had all the same issues.

The following day I called Autel Robotics and explained what was going on. They said what I was describing was very, very strange. They said they were going to ship me a new battery and to please send Battery #3 back to them for inspection. I asked if I should perform a gimbal and compass calibration and they said no. To never perform any calibration unless instructed to do so by the app - even after a firmware update. That doing so could lead to other problems.

The following day, the skies cleared and decided to take her for my second spin. Perfect conditions with 16 sats and fully charged topped off Battey #1 and controller. What you're about to see is very odd. Since there is no audio, let me explain what's taking place in the video. I took off facing me and noticed that the horizon looked skewed against my roof line. I saw a YouTube video that said we can now adjust the Gimbal Roll Axis. I got to about the roof line of my house, hovered and entered that setting within the app. I tapped on the left then the right to adjust the axis but wasn't sure if I was getting a true representation of a centered horizon. I then yawed my Evo facing away from me and gained some altitude to see the actual horizon. I tapped to the roll axis to the left when I noticed I was tapping in the wrong direction then tapped to the right. I over compensated then tapped on the left. When I thought I had everything centered, I tapped out of Settings then my gimbal suddenly dropped. I couldn't figure out was going on so I attempted to roll the gimabl up but no joy, it wouldn't budge up. I rolled the gimbal down and realized that I was now looking behind my Evo! I thought only porn stars could do that!

I tried to roll up again and it wouldn't move past facing straight down. I then decided to obviously land. As I was doing so, about 3 feet off the ground, I yawed back so that the front of the Evo was facing me. Right then, my gimbal tilted sideways and remained that way till I landed.

I powered everything off, checked the gimbal and everything looked fine. I powered up controller then Evo and app and the gimbal performed its usual dance. I took off and had no problems. No compass or gimbal calibration prompts, nothing. It was perfect short test flight. I then landed, powered off then powered on then flew again without any more problems. The following day I reached out to Autel and showed them the video of the flight. They claimed they had never seen anything like that. That since I had the Evo for only about a week, to take it back to Best Buy and get it replaced. I did that two nights ago and am looking forward to flying my "newer" Evo.

Check out the video:

In conclusion, my gut is telling me that I experienced two separate problems. The first was the battery. I've seen others report issues with sudden magnetic interference issues and app disconnects and re-coonects. I can safely say that those errors are were probably due to a bad battery which is causing anomalous errors within the app and controller software.

I believe the gimbal issue was possibly due to trying to adjust the gimbal roll axis in midflight and tapping on extremes (roll axis all the way to the left then right) which cause the gimbal software to "run home to momma" and give up. It obviously didn't loose power since I was able to record the whole event. I'd ask some of you to try to replicate what I did using gimbal roll axis during flight, but I don't want you to damage your gimbal by trying it. I would love to know for sure what caused this in-flight malfunction and isolate the issue. One thing is certain, if there is a problem with gimbal roll axis in mid-flight, we all need to know about it.

Lastly, after watching the video I noticed a strange gimbal movement right after playing with the gimbal roll axis while it was pointing at my roof. Something I didn't notice since I was in the Setting menu during the flight.

Guys - sorry for the long *** story and all the minute details but hopefully my event will go a long way in helping someone else out.

All in all, Autel was wonderful in addressing my concerns and provided the excellent support they're known for.

Wish me luck on my next maiden flight. Hey at least I got to peel the plastic film off two Evos - how many people do you know that can make that same claim :)

Tight lines and smooth flights ~
Mine has done this with the gimbal before and it’s honestly because too much adjusting will cause it to spaz out if done to quick. Tap twice and let the camera align, tap twice and let align. I’ve went from .2-1.0 and it goes straight down without being able to raise and sometimes two tapping to much and giving it time to adjust doesn’t work. For future, go into settings and throw on horizontal lines and do it right in front of you or sitting on a flat surface so you know it’s safe. Also, for the updates.....Autel released a thing a while back saying firmware updates done to the evo via computer needs each battery updated but ota does not, I found this wasn’t true though, or didn’t prompt me to update each battery. If you’re still experiencing horizon tilt then go into settings and format the sd card, power everything off and power it all back on. Wait a minute or two and it should prompt you to update to the newest 1.3.3.25 or something like that. Sucks for all this but at least there’s forums for help and other people have experienced the same. Oh, and Best Buy has price matched amazon for years, but it has to be sold and shipped by amazon and not a third party using amazon. One of the only major retailers to do so.
 
  • Like
Reactions: mixchief and Ansia

snow86man

Well-Known Member
Joined
Jan 19, 2019
Messages
53
Reaction score
40
Age
38
2 things.

1) Now we know that the Mars Rover isn't the only machine that can take selfies.

2) You need to speak with your neighbors about getting different colored cars. There is more to this world than gray and white cars. *insert laughing emoji here*

I really enjoyed your story. You should consider becoming a novelist.
different colored cars
 

Autelguy

Well-Known Member
Joined
Feb 1, 2018
Messages
179
Reaction score
98
Age
55
Mine has done this with the gimbal before and it’s honestly because too much adjusting will cause it to spaz out if done to quick. Tap twice and let the camera align, tap twice and let align. I’ve went from .2-1.0 and it goes straight down without being able to raise and sometimes two tapping to much and giving it time to adjust doesn’t work. For future, go into settings and throw on horizontal lines and do it right in front of you or sitting on a flat surface so you know it’s safe. Also, for the updates.....Autel released a thing a while back saying firmware updates done to the evo via computer needs each battery updated but ota does not, I found this wasn’t true though, or didn’t prompt me to update each battery. If you’re still experiencing horizon tilt then go into settings and format the sd card, power everything off and power it all back on. Wait a minute or two and it should prompt you to update to the newest 1.3.3.25 or something like that. Sucks for all this but at least there’s forums for help and other people have experienced the same. Oh, and Best Buy has price matched amazon for years, but it has to be sold and shipped by amazon and not a third party using amazon. One of the only major retailers to do so.
In regards to Amazon price matching, yes. You're right. I forgot to mention that caveat. Still though, it sounds like Best Buy is getting serious and trying to keep up sales. It's a smart move and make is very convenient for consumers if we happen to need something now.
 

snow86man

Well-Known Member
Joined
Jan 19, 2019
Messages
53
Reaction score
40
Age
38
In regards to Amazon price matching, yes. You're right. I forgot to mention that caveat. Still though, it sounds like Best Buy is getting serious and trying to keep up sales. It's a smart move and make is very convenient for consumers if we happen to need something now.
Trust me, I applaud it. Walmart will only Mach their online price if they have it in stock according to online. They had a great sale online on sd cards once and I grabbed a cpl off the shelf and asked about price matching their online. They looked it up and said the same ones I was holding was out of stock and they would not price match it, but I could order it and pick it up within an hr. Best Buy matching amazon works for me entirely
 

Wayne Maine

Well-Known Member
Joined
Sep 26, 2017
Messages
102
Reaction score
44
Age
73
When doing a gimbal cal it will go to about 120 degrees rearward. You can even shoot a photo when it does this. It will also point upward.
 

Tman1265

Member
Joined
Aug 15, 2018
Messages
24
Reaction score
7
Age
56
When I bought my Nikon camera at BB, they priced matched B&H photo right down to throwing in an extra battery and a "similar" camera case that B&H was including in their bundle.
 

mixchief

Well-Known Member
Joined
Jul 26, 2018
Messages
444
Reaction score
168
Age
63
2) You need to speak with your neighbors about getting different colored cars. There is more to this world than gray and white cars. insert laughing emoji here

I really enjoyed your story. You should consider becoming a novelist.
HEY I work at a dealership, Our lot looks just like that, that is what everyone wants believe it or not, I am in South Florida, most popular car color? BLACK ON BLACK ...... go figure!
 
  • Like
Reactions: Ansia

Ansia

Well-Known Member
Joined
Jan 10, 2019
Messages
1,024
Reaction score
514
HEY I work at a dealership, Our lot looks just like that, that is what everyone wants believe it or not, I am in South Florida, most popular car color? BLACK ON BLACK ...... go figure!
I used to work for a Toyota dealer. Sadly, this is true.
 
  • Haha
Reactions: mixchief

GLEvideo

Well-Known Member
Joined
Nov 1, 2018
Messages
50
Reaction score
23
I hope you get all the bugs worked out with either new hardware or software adjustments. Just thinking maybe we should start a new thread of problems and issues and the fixes. I can tell you that I have seen two problems - one of my batteries wouldn't charge and the third light kept flashing. After messing with it for about 5 - 10 minutes I figured out that I could turn the battery off by holding the button in for several seconds. Then after letting it sit for about 10 minutes it would start taking a charge. My thinking is that it was too cold to start charging as I had it sitting outside in near freezing temps for quite a while prior.

Second problem has just started right after I updated to the latest firmware. I used to have spot on accurate auto landings within an inch or two. Now with the new firmware the landings are all over the place as much as 6 - 8 feet off. Sometimes they are within 6 inches. I have a nice easy to recognize geometric pattern in the flat level driveway for the EVO to key it's landings off of. I've reloaded the firmware, rebooted and then calibrated the compass and still the problem persists. No fix found for this yet.
 

Latest threads

Members online

Forum statistics

Threads
3,515
Messages
33,242
Members
2,253
Latest member
Panonhas